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Before You Start

The following sections provide an overview of the book.

About This Book..........................................................................................................  6 

About This Book

This guide describes how to use the following ShoreTel Enterprise Contact Center supervisor 
applications: 

 Agent Manager

 Contact Center Reports 

 Wallboard Director

This guide is intended for call center supervisors.

Organization

The document is divided into the following chapters:

 Chapter 1, Overview

 Chapter 2, Monitoring Activity

 Chapter 3, Analyzing Trends

 Chapter 4, Communicating with Agents

Conventions

The following typographical marking conventions are used in this document.

Marking Meaning

Bold Names of interface objects, such as buttons and menus. 

Courier Code examples.
ShoreTel Enterprise Contact Center ShoreTel Contact Center Supervisor Guide 6



Before You Start Conventions
Courier Italic Variables in code examples.

Blue Cross references with hyperlinks. Click the blue text to go to the indicated 
section. All chapters have a list of section links on the first page. 

Note: Table of Contents entries are also links, but they are not shown in blue. 

Marking Meaning
ShoreTel Enterprise Contact Center ShoreTel Contact Center Supervisor Guide 7



CHAPTER
1. Overview

ShoreTel Enterprise Contact Center includes three applications for supervisors: Agent Manager, 
Contact Center Reports, and Wallboard Director. Using these applications you can monitor Automatic 
Call Distribution (ACD) activities, generate reports on call center performance, and display messages 
on wallboards. Multiple supervisor workstations can be activated simultaneously, allowing a number of 
supervisors and managers to work on various tasks at the same time. 

Refer to the following sections for more information about Contact Center supervisor applications:

Agent Manager............................................................................................................  8

Contact Center Reports ..............................................................................................  9

Wallboard Director.......................................................................................................  9

Terminology.................................................................................................................  9

Starting the Supervisor Applications .........................................................................  11

Agent Manager

Agent Manager is used by managers and supervisors to obtain real-time statistical information 
concerning call center activities. The information can be displayed in tables, forms, and graphic 
formats, providing a clear picture of what is going on in your call center.

Agent Manager also enables supervisors to adjust their resources by adding and removing agents 
from groups.
ShoreTel Enterprise Contact Center ShoreTel Contact Center Supervisor Guide 8



Overview Contact Center Reports1
Contact Center Reports

Contact Center Reports generates historical statistical reports that you can use in evaluating past 
activities and planning future actions. The application contains a variety of predefined reports that can 
be quickly generated. In addition, you can create reports based on an extensive set of easily 
customizable templates.

Wallboard Director 

Wallboard Director is used to control the messages displayed on external and desktop agent boards. 
Messages can be made up of both free text and statistical parameters. Free sequences can be defined 
as a scenario or as popup messages and sent automatically.

Terminology

The following list includes basic terminology you must understand to successfully create Contact 
Center reports:

 ACD — Automatic Call Distribution. The method used to distribute calls in Contact Center. ACD 
calls are routed and monitored by the ShoreTel system. 

 Agent — An operator who handles calls in a call center. 

 Agent Group — Agent groups form specialized units that receive and place calls. A group is a 
destination of the service entity in ShoreTel Contact Center Solution. Calls delivered to the group 
are presented to the most appropriate agent according to the specified routing policy. 

 Agent Queue — Contact Center provides each agent with a personal queue, allowing voice calls 
(only) to be queued for that specific agent. This powerful and useful feature is extremely relevant 
for sales oriented and direct marketing organizations where individual agents are responsible for 
accounts. This functionality can also improve customer service in call centers with a small number 
of agents and fluctuating amounts of traffic, since agents can address higher priority calls while 
transferring their current interaction into their personal queue. Calls can also be routed to an 
individual agent first, and then expanded to a larger set of agents if the primary agent is not 
available. In addition, agent queues can be used as a routing destination by a service, IRN, or call 
control script.

 ANI — Automatic Number Identification. The series of digits that is sent by the PSTN to the PBX 
containing the Dial Number of the caller. 

 ANI Domain — A set of 1 or more Telephone number prefixes (part of which may be whole 
telephone numbers) grouped under a domain name for statistical purposes.

 ASA — Average Speed of Answer. The average time it takes for a call to be answered, from the 
time it is received.
ShoreTel Enterprise Contact Center ShoreTel Contact Center Supervisor Guide 9



Overview Terminology1
 DNIS — Dialed Number Identification Service. A series of digits that precede a phone call with the 
number the caller dialed.

 Entity — Administrative objects in the ShoreTel system, upon which system operations are based. 
These are agents, groups, trunks, supervisors, services, IRN, domains, customers, DNIS, dial 
lists, IVR groups, IVR applications, email accounts, and system. 

 Group — Several agents or trunks that function as one unit for call handling purposes. 

 Interval, Historical Reports — Also known as an off-line interval. A system-wide parameter that 
defines the resolution for saving statistical data into the database. For historical reports, the 
interval may be 15, 30, or 60 minutes. 

 Overflow — Overflow is a routing technique that can improve customer service and optimize 
valuable resources. Highly trained or cross-trained agents are reserved as backups for groups 
experiencing unusually heavy call traffic. When the caller wait time exceeds the specified timeout, 
backup resources are automatically added to the pool and made available to handle customer 
calls.

The overflow timeout is the number of seconds a call is in queue, after the mandatory 
announcement. This value is specified in the Services > Overflow > Overflow Timeout option in 
Contact Center Director. 

 Parameter — Defines the reporting criteria, specifically a report’s entities, date range, time range, 
and interval, where applicable. 

 STI — Service Time Interval. The time period that serves as a starting point for Contact Center 
statistical information. This parameter determines the time period within which calls waiting in the 
queue are measured in historical reports. The STI is defined for each group in the system using 
ShoreWare Contact Center Director.

 TSF — A measurement that indicates how well the entity, such as a group or DNIS number, is 
providing the Target ASA (Average Speed of Answer). The TSF may be calculated in one of the 
following three ways: 

 The percentage of calls answered within the Target ASA, out of all the measured entity’s calls. 
Abandoned and overflowed calls are considered answered after the Target ASA; 

 The percentage of calls answered within the Target ASA, out of calls answered by the 
measured entity; and 

 The percentage of calls answered within the Target ASA, out of calls answered by the 
measured entity and calls abandoned after the Target ASA.

 Wrap-Up Code — A code entered by an agent during the wrap-up time in order to provide 
additional information for evaluating the actions of the call center. In most cases, wrap-up codes 
provide information for evaluating calls for reporting purposes, including the type of call — request 
or complaint; level of required action — urgent, regular, or low; status of the deal — closed, needs 
recall; and so on.
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Starting the Supervisor Applications

Each Contact Center supervisor application is started separately. You must use a password to log in to 
Contact Center applications.

Supervisors can log in using their supervisor ID or the agent name associated with their Supervisor 
account in Supervisors > Accounts > General > Agent Name.

Supervisors also can start applications by right-clicking the login console icon that appears in the 
Windows task bar. 

Starting Agent Manager

1. From the Windows desktop, click Start > All Programs > ShoreTel > ShoreWare Contact 
Center Supervisor > ShoreWare Agent Manager.

If the Agent Manager icon is on your desktop, or in the Windows Start menu, you can click this icon 
to start Agent Manager.

2. In the ShoreTel Contact Center Logon window, specify User, Password, Extension, and Server, 
and then click Login.

Starting Contact Center Reports

1. From the Windows desktop, click Start > All Programs > ShoreTel > ShoreWare Contact 
Center Supervisor > ShoreWare Contact Center Reports.

If the Contact Center Reports icon is on your desktop, or in the Windows Start menu, you can click 
this icon to start Contact Center Reports.

2. In the ShoreTel Contact Center Logon window, specify User, Password, Extension, and Server, 
and then click Login.

Note

Contact Center supervisor applications should not be used with the following Windows Power 
Schemes: Turn off hard disks, System standby, and System hibernates. These options should be set 
to Never because the Contact Center Server and the supervisor applications are synchronized every 
night at midnight. If your computer is set to one of these options, the synchronization fails.

Tip

If not all of the fields listed in this step are visible, click More to expand the Contact Center Login 
Console window. 
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If your server is not listed in the drop-down menu, click Servers to add the server to the list. 

Starting Wallboard Director

1. From the Windows desktop, click Start > All Programs > ShoreTel > ShoreWare Contact 
Center Supervisor > ShoreWare Wallboard Director.

If the Wallboard Director icon is on your desktop, or in the Windows Start menu, you can click this 
icon to start Wallboard Director.

2. In the ShoreTel Contact Center Logon window, specify User, Password, Extension, and Server, 
and then click Login.

Tip

If not all of the fields listed in this step are visible, click More to expand the Contact Center Login 
Console window. 

Tip

If not all of the fields listed in this step are visible, click More to expand the Contact Center Login 
Console window. 
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CHAPTER
2. Monitoring Activity

Agent Manager provides tools, and real-time statistical information, to manage your agents and inform 
you about the current situation in your call center.

This chapter explains how to change agent group assignments, monitor agent interaction with 
customers, and work with real-time reports. Refer to the Agent Manager online help for details on a 
specific real-time report.

Refer to the following sections for more information about monitoring Contact Center activity:

Changing Agent Group Assignments........................................................................  14

Monitoring Agent Interaction with Customers ...........................................................  15

About Real-Time Reports..........................................................................................  17

Creating Real-Time Reports......................................................................................  21

Opening Existing Real-Time Reports ........................................................................  22

Working with Graphical Reports................................................................................  22

Saving Real-Time Reports ........................................................................................  22

Modifying Real-Time Reports....................................................................................  23

Setting the Refresh Rate...........................................................................................  25

Saving a Workspace .................................................................................................  25

Changing Agent Group Assignments

Agent Manager’s Login Manager enables you to change the group and agent queue assignment of 
agents currently working in the call center. The Login Manager has two optional views: Agent Login 
Status and Group Login Status. In the Agent Login Status view, you can see an agent’s current group 
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Monitoring Activity Monitoring Agent Interaction with Customers2
and agent queue assignments. You can then add or remove groups to and from the agent. The Group 
Login Status view allows you to see the agents currently logged into a specific group and agent queue. 
You can then add or remove agents to and from the group.

Note that agents can enter wrap-up code on an ACD interaction even if they are logged out of a group.

Complete one of the following steps to open the Login Manager:

 Click the Login Manager icon on the Toolbar.

 Right-click a report based on the Group Agents Report or Brief Agent Report templates, and then 
select Login Manager from the popup menu.

The Agents Login Status tab includes the following items:

 Agents — Lists all agents currently logged into the system.

 Name — The name of the agent

 Number — The ID number of the agent

 Logged-in Groups — Lists the groups and agent queues that the selected agent is currently 
logged into.

 Available Groups — Lists the groups and agent queues that the agent is currently not logged into.

The Groups Login Status tab includes the following items:

 Groups — Lists all groups and agent queues defined in the system.

 Logged-in Agents — Lists the agents currently logged into the selected group or agent queue.

 Available Agents — Lists the agents currently not logged into the selected group or agent queue, 
but logged into at least one other group or agent queue.

Monitoring Agent Interaction with Customers

Contact Center provides various ways to monitor agent interaction on customer calls and chat 
sessions.

Monitoring Customer Calls

You can monitor agent calls using the following Agent Toolbar features: 

 Silent Monitor — Allows you to listen in on a call without either the agent or the customer 
knowing.

 Barge-In — Enables you to participates in a call, with both the agent and customer hearing your 
conversation.

For more information about using Agent Toolbar, refer to the Using Agent Toolbar guide.
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Complete the following steps to monitor calls:

1. Launch Agent Toolbar.

2. To silently monitor a call, click the Silent Monitor button .

If the Silent Monitor button is programmed with the number to monitor, the system automatically 
connects you to that number’s current call.

If the button is not programmed with the number to monitor, the Silent Monitor dialog box appears. 
Use the Silent Monitor dialog box to enter the number to connect to, or select a recently connected 
number from the drop-down list. 

3. Click OK.

4. To barge-in on a call, click the Barge-In button .

If the Barge-In button is programmed with the number to monitor, the system automatically 
connects you to that number’s current call.

If the button is not programmed with the number to monitor, the Barge In dialog box appears. Use 
the Barge-In dialog box to enter the number to connect to or select a recently connected number 
from the drop-down list. 

5. Click OK.

Monitoring Chat Sessions

You can monitor chat sessions between agents and customers using any of these modes:

 Silent Monitor — Allows you to watch a chat session without either the agent or the customer 
knowing.

 Coach — You can provide information and directions to the agent through chat messages that 
only the agent sees. Your chat messages to the agent are not included in the chat session 
transcript.

 Barge-In — Enables you to participate in the chat session. Both the agent and customer see your 
chat messages, which are included in the chat session transcript.

In order to monitor chat sessions, you must have the Contact Center Chat feature installed and 
configured. You also must know the IP address of the Tomcat Server used to run the chat Java 
servlets.

Complete the following steps to monitor chat sessions:

1. Point your browser to http://[Tomcat Server IP address]:8080/ECCChat/supchat.html.

2. Enter your Name, Username, and Password, and then click Login.
ShoreTel Enterprise Contact Center ShoreTel Contact Center Supervisor Guide 16



Monitoring Activity About Real-Time Reports2
The Name you enter is used to identify you in a chat session if you are participating via either the 
Coach or Barge-In features. The Username and Password are the same as used to log into your 
Contact Center supervisor applications.

3. In the resulting window, select the specific chat session you want to connect to from the list of all 
current chat sessions. The chat window for the selected session is displayed.

To log out of the Supervisor Chat application, click Logout.

4. In the chat window, select how you want to monitor the chat session by clicking Silent Monitor, 
Coach, or Barge-In.

5. If you choose either Coach or Barge-In, type your chat message in the text area and click Send. 
Your message is shown in the chat window using the name you specified when logging into the 
application.

6. If you are using either the Coach or Barge-In feature, you can insert predefined chat responses by 
locating and selecting the appropriate file in the Chat Responses window.

The chat response files are identified using System Parameters > Chat and Email > Chat > 
Responses in Contact Center Director. Refer to the Enterprise Contact Center Administrator 
Guide for details.

7. To toggle between multiple chat sessions, click Hide to minimize the chat window tab of a 
particular chat session

8. Click Show Chats to return to the list of all current chat sessions.

9. Select another chat session.

All chat sessions are represented in a tab. Click a tab to view the associated chat session.

10. To end participation in a chat session, click Disconnect. 

11. To log out of the Supervisor Chat application, click Logout in the Chats tab.

About Real-Time Reports

The reports generated through Agent Manager provide data on call center activity in real time. These 
reports can be used in the management of agents and to watch the changing conditions in the call 
center. Alerts indicate when a specific threshold is reached or exceeded.

Real-time reports have a template that you use to specify the criteria for the data in the report. Three 
types of real-time report templates exist: real-time, hourly summary, and daily summary.

Note

Ensure that logon credentials for supchat.html are tightly controlled to help prevent a breach of 
security.
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Information in real-time reports are displayed in tabular or graphical formats, or as a form. You can 
save an arrangement of reports on your workspace (desktop); the display remains consistent each 
time you start Agent Manager.

Using Thresholds

By default, Agent Manager specifies thresholds for real-time group activity. Information on this activity 
is displayed by running specific reports. When the activity, such as number of calls in queue, reaches 
or exceeds a threshold, you receive an alert. The data in the report is usually highlighted in yellow 
when the threshold is reached, and in red when the threshold is exceeded. Thresholds are defined 
using Groupings > Groups > Thresholds in Contact Center Director.

In addition to a color indicator, an audible alert is available. This alert can either be a system beep or a 
sound from a WAV file, and the alert can play once or continuously for a specified period of time. Alerts 
are configured using Supervisor > Alerts in Contact Center Director.

Agent Manager provides two default files used as the audible alerts, warning.wav and alarm.wav. 
When data meets or exceeds the yellow threshold level, the sound in the warning.wav file is used. 
The alarm.wav file sounds when the data meets or exceeds the red threshold level. You can use 
custom alerts by recording or using an existing WAV file. Save your custom sounds in the 
Supervisor\Bin folder of your Contact Center directory with the filename custom_warning.wav 
and custom_alarm.wav.

Contact your system administrator to implement or change threshold levels for specific group 
activities. In order to use audible alerts, your system must be configured for this feature. Check with 
your system administrator if you have questions about using or implementing audible alerts.

 White — Value is in the normal zone.

 Yellow — Value is in the warning zone.

 Red — Value is unacceptably high or low.

The Threshold tab contains the following information:

 Name — Name of the event that the threshold is specified.

 Yellow — Threshold has been exceeded.

 Red — Threshold has been exceeded to an unacceptable level.

 Up — If checked, indicates that the parameter counts up to go from White to Yellow to Red. 
Uncheck means that the parameter counts down.

Real-Time Report Templates

Real-time reports are based on three types of templates: real-time, hourly summary, and daily 
summary.
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Real-time templates show statistical and summary data on agents for the recent time interval. The 
real-time interval is specified using Groupings > Groups > General in Contact Center Director. Using 
reports generated from a real-time template, you can watch the data change as events occur in your 
call center. 

Hourly summary templates are used to generate reports that display hourly statistics and summary 
data for selected groups. Each row in the report shows data for the interval starting from the time 
shown until the start time of the next interval. Data is not displayed until the time interval has 
completed. For example, data on the 16:15 interval would not be displayed until the time was 16:30.

Daily summary templates shows statistical and summary data for a group of agents. Data is calculated 
over the entire day starting at midnight and ending at the following midnight.

Template Subjects 

The subject of a template can be one of the following entities:

 Agents — An operator who handles calls in a call center.

 Groups — A group of agents. There are different group templates for voice call flows and email 
flows. 

 Agent Queues — Allow calls to be queued for a specific agent. 

 IVR Applications — Sections of logic defined in call control scripts.

 IVR Ports — A grouping of IVR applications. 

 Dial Lists — Used for outbound calling campaigns and are sets of telephone numbers that are 
automatically dialed and routed to agents. From this report, you can end the activity of a currently 
running dial list by clicking Terminate.

 DNIS — Associated with a specific IRN, which is the first point of entry into Contact Center. There 
are different DNIS reports for voice call flows and email flows.

Daily Summary Templates

The following daily summary templates are available for generating real-time reports:

 Daily Brief Agent Queue Report

 Daily Brief Email Group Report

 Daily Brief Group Report

 Daily Detailed Email Group Report

 Daily Detailed Group Report

Tip

Contact Center puts calls into queue(s) associated with a group of agents. To view queue 
statistics, use a group template.
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Hourly Summary Template

Contact Center provides the following hourly summary template for generating real-time reports:

 Group Hourly Report

Real-Time Templates

Use one of the following real-time templates to generate a report on the recent time interval:

 Agents Distribution Graph

 Agents Needing Help

 Brief Agents Report

 Brief Agent Queue Report

 Brief Dial List Report

 Brief DNIS Report

 Brief Email DNIS Report

 Brief Email Group Report

 Brief Group Report

 Brief IVR Applications Report

 Calls Distribution Graph

 Detailed Email Group Report

 Detailed Group Report

 Detailed IVR Applications Report

 Email Contacts Distribution Graph

 Email Group Overflow\Interflow Report

 Email Group Queue Contacts Graph

 Email Group STI Graph

 Graphical Agents Report

 Group Agents Report (1)

 Group Agents Report (2)

 Group OACD STI Graph

 Group Overflow\Interflow Report
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 Group Queued Calls Graph

 Group Queued OACD Calls Graph

 Group STI Graph

 IVR Applications ACD Distribution Graph

 IVR Applications Active ACD Graph

 IVR Applications Active OACD Graph

 IVR Applications OACD Distribution Graph

 IVR Group IVR Ports Report

 IVR Ports Distribution Graph

 IVR Ports Report

 Staffing Graph

 Staffing Percent Graph

 Staffing Percent Report

 Staffing Report

Creating Real-Time Reports

You can create a new real-time report for current information on your call center. 

If you want to generate reports on call activity in an IVR Application, you first need to specify the 
associated DNIS. Refer to Generating Reports on IVR Applications on page 48 for details.

Complete the following steps to create a real-time report:

1. Click File > New, or click the New icon on the Toolbar. 

2. The New dialog box appears.

3. Select a Report Type. 

4. Select a Template Name, and click OK.

5. You can change the sort order of the entities in the list by clicking the entity title. 

Entities listed alphabetically are displayed in reverse alphabetical order; entities listed by number 
are displayed in reverse numerical order.

6. Select the required entity, and click OK. 
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The window title bar indicates that the report is untitled, and displays the name of the template on 
which the report is based. 

Any current activity in the ACD is immediately reflected in the report. 

For information about the data displayed in these reports, refer to the Report Data Fields 
Reference Guide.

Opening Existing Real-Time Reports 

Complete the following steps to open an existing real-time report:

1. Click File > Open or click the Open icon on the Toolbar. 

2. To narrow the list of reports displayed, select Public and/or Private, and select the Report Type. 

3. Select the report to open, and click OK. 

Working with Graphical Reports

The Graphic Toolbar is displayed at the top of graphical report windows.

You can use the following Toolbar features to change the way a graphical report is displayed: 

 Palette Selector (1) — Change the color scheme based on predefined palettes. 

 Points Labels (2) — Show or hide the labels for the points of the graph.

 Legend Box (3) — Show or hide the legend.

Not all the features available from the Toolbar are applicable to all graphical reports. Those not 
available for a specific report are grayed out. 

Saving Real-Time Reports 

A report can be saved in both the public and private report lists. All authorized supervisors can view 
public reports, but only you who created them can view private reports. 

Complete the following steps to save a real-time report:

1. To save a report with its current properties, click File > Save or click the Save icon on the Toolbar. 

To save a report for the first time, you must click File > Save; the Save icon is disabled.

2. To save a report with a new file name, or to save a private report as public (or the reverse), click 
File > Save As or click the Save As icon on the Toolbar. 
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3. Use the Save As dialog box to specify the name and location of the report.

Modifying Real-Time Reports

After you create a real-time report, you can modify the report to reflect the data you want to see:

 Change the entity a report is based on.

 Add entities to a report.

 Remove entities from a report.

 Reorder items in a tabular report.

 Change the order of fields in a tabular report.

 Add and remove fields in a tabular report.

Changing the Report Entity

For reports based on only one entity, you can change the entity without having to create a new report. 

Complete the following steps to change the report entity:

1. From an open report, click Contents > Change or click the Change icon on the Toolbar. 

2. If you want to change the sort order of the entities, click the entity title. 

Entities listed alphabetically are displayed in reverse alphabetical order; entities listed by number 
are displayed in reverse numerical order.

3. Select the entity that you want the report to now be based on.

4. Click OK. 

Adding Entities to Reports

You can add entities to an existing report to change the content and create a different report without 
having to create a new report.

Complete the following steps to add an entity to a report:

1. In an open report, click Contents > Add or click the Add icon. 

2. If you want to change the sort order of the entities, click the entity title. 

Entities listed alphabetically are displayed in reverse alphabetical order; entities listed by number 
are displayed in reverse numerical order.

3. Select the entity to add to the report, and then click OK. 
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Removing Entities from Reports

You can remove entities from an existing report to change the content and create a different report 
without having to create a new report.

Complete the following steps to remove an entity from a report:

1. From an open report, click Contents > Remove or click the Remove icon on the Toolbar. 

2. If you want to change the sort order of the entities, click the entity title. 

Entities listed alphabetically are displayed in reverse alphabetical order; entities listed by number 
are displayed in reverse numerical order.

3. Select the entity to remove from the report, and then click OK. 

Reordering the Items in a Report

For tabular reports, you can change the order of the items in the report to be sorted by name, number, 
or extension number (if applicable).

Complete the following steps to reorder the items in a report:

1. From an open report, click Contents > Reorder or click the Reorder icon on the Toolbar. 

2. Select the sort criteria, and then click OK.

Changing the Order of Fields in a Report

To change the field order, click the header of the field you want move, and then drag the field to its new 
location in the report.

Adding and Removing Fields in a Report

Complete the following steps to add or remove fields in a report:

1. From an open report, click the Add/Remove Columns icon on the Toolbar. 

2. To add a field, select the field(s) in the Available Columns list, and click Add.

3. To remove a field, select the field(s) in the Visible Columns list, and click Remove.

4. Click OK. 
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Setting the Refresh Rate

The refresh rate defines how often Agent Manager requests an update from the server. By default, the 
refresh rate is one second. You can instead set a refresh rate that is automatically determined based 
on the network load, or set a specific rate.

Complete the following steps to set the refresh rate:

1. If you want the system to automatically set the refresh rate depending on the load of the network, 
click Tools > Refresh Rate > Automode.

2. If you want to set a specific refresh rate, click Tools > Refresh Rate > Manual Mode.

3. Select the refresh rate, in seconds, and then click OK.

If the manually set refresh rate is determined by the system to be insufficient for the current 
network load, the system automatically increases the rate to a more efficient number.

Saving a Workspace

You can save a personal workspace such that, each time you start Agent Manager, the reports you are 
most interested in are automatically displayed and updated.

Complete the following steps to save a workspace:

1. Open, create, modify, and place the reports you want to automatically see each time you start 
Agent Manager.

Use the commands from the Windows menu to place and order the reports in a layout you want.

2. Click File > Workspace > Save As Default. 

3. You can revert to your default workspace by choosing File > Workspace > Restore Default.

Note

If an activity begins and ends before the next update of information, this activity is not reported in the 
report. For example, if the refresh rate is 5 seconds and an agent speaks on a call for 3 seconds, this 
call is counted as a call but there will be no change in the agent state.
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CHAPTER
3. Analyzing Trends

Historical reports are used to obtain information about past call center activity. The powerful, yet easy 
to use, Contact Center Historical Reports application provides activity summaries and statistical data 
that can help you analyze system behavior and aid in the assessment of resources required to meet 
target service levels.

Additional powerful tools (including sorting by fields, filtering of data by user-defined criteria, and 
defining of noncontinuous periods) are provided to support a comprehensive and flexible environment 
for generating sophisticated reports without requiring you to know about database tables, SQL queries, 
or programming languages.

An integrated scheduler enables automated reports to be printed, emailed, or exported to a variety of 
external format (such as Excel, HTML, and PDF) at required times.

Historical data on your call center can be retained for 12 or 24 months. This allows you to run historical 
reports on trends for the current year vs. the previous year. The default retention period is 12 months. 
Refer to the Contact Center Administrator Guide for information on changing the length of time to 
retain historical data to 24 months. 

This chapter explains how to work with historical reports. Refer to the Contact Center Reports online 
help for details on a specific historical report.

Note

Generating a report may take several minutes. While the report is generating, do not use the Contact 
Center Reports application. Doing so results in the error message “Error retrieving rows,” and the 
report generation is halted.
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Refer to the following sections for more information about analyzing Contact Center trends:

About Historical Reports ...........................................................................................  27

Creating a Historical Report Using a Predefined Template.......................................  31

Launching the Open Window....................................................................................  32

Viewing Only Public and/or Private Templates..........................................................  32

Opening a Predefined Template................................................................................  33

Specifying Template Parameters...............................................................................  33

Customizing a Template............................................................................................  35

Saving a Template with a New Name .......................................................................  40

Generating a Report..................................................................................................  40

Deleting a Predefined Template ................................................................................  43

Creating a Historical Report Using a Blank Template ...............................................  44

Working with Historical Reports ................................................................................  45

Generating Reports on IVR Applications ..................................................................  48

Understanding Historical Report Results ..................................................................  50

About Historical Reports

Historical reports are generated from predefined or blank templates that can be configured to include 
specific data fields and entities. Templates can also be customized for a unique look. Some reports 
can be generated to display in either a tabular or graphical format. 

Historical Report Templates

Historical reports are based on predefined or blank templates. Predefined templates contain 
commonly used data elements, which you can change. Using predefined templates can save you time, 
since the data elements you want may already be defined. 

Blank templates do not contain data elements; which you must add to the template. Blank templates 
are useful when trying to match an existing report from another source.

Historical reports are based on a date or range of dates, or on an interval. (The historical interval is 
specified using Contact Center Director > System Parameters > Reporting Preferences > Reporting 
Settings). Historical reports based on an interval are commonly used to show averages and summary 
data based on the time of day. By Interval historical reports provide call center statistics based on time 
intervals set in the report criteria. By Interval reports that span multiple days display fractional data 
values in the report.

Template Subjects (Entity)

You can identify the subject of a template by the icon associated with the template in the Open and 
New dialog box lists. 
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 Agent — If you generate a historical report on a large number of agents, the report may show the 

entire list of agents in the Agent Name field, but no data is displayed. In this instance, contact your 
system administrator. The administrator must add the value reduce_header_size=1 to the [Admin 
Configuration] section of the wecc.ini file on your PC.

You can select up to 400 agent entities per report.

 ANI Distribution — Calls grouped by ANI, which is specified in Contact Center Director > 

Domains > ANI Prefixes

Dial List — Outbound calls performed by the system. The success and failure of the calls are 

shown.

 DNIS — The DNIS associated with a specific IRN (the first point of entry into Contact Center). 

There are different DNIS reports for voice call flows and email flows generally used to report on the 
experience from the service point of view.

You can select up to 400 DNIS entities per report. However, note that reports with more than twenty 
DNIS entities will take additional time to generate.

 Group — A group of agents. There are different group templates for voice call and email flows.

You can select up to 255 group entities per report.

 IVR Applications — Sections of logic defined in call control scripts.

 IVR Ports — A grouping of IVR applications.

 Release Code — Used to label the activity of an agent.

 Wrap-Up Code — Used to label the type of call received by the agent.

Predefined Templates

The following predefined templates are available for generating historical reports:

 BP1.1 WFM- Blue Pumpkin Report

 RA1.1 Agent Performance Report by Interval

Tip

Use a group template if you want to see queue statistics, since Contact Center puts calls into queue(s) 
associated with a group of agents.
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 RA1.2 Agent Performance Report by Date

 RA2.1 Group Agents Performance Report

 RA3.1 Agent Activity Log Report

 RG1.1 Group Performance Report by Interval

 RG1.2 Group Performance Report by Date

 RG2.1 Group Staffing Report by Interval

 RG2.2 Group Staffing Report by Date 

 RG3.1 ACD Calls Distribution by Interval

 RG3.2 ACD Calls Distribution by Date

 RG4.1 Abandoned Calls Analysis by Interval

 RG4.2 Abandoned Calls Analysis by Date

 RG5.1 Detailed Group Wrap-Up Report by Interval

 RG5.2 Detailed Group Wrap-Up Report by Date

 RG6.1 Group Wrap-Up Code Report

 RG7.1 Abandoned Calls Log

 RQ1.1 Agent Queue Report by Interval

 RQ1.2 Agent Queue Report by Date

 RS2.1 ACD Calls Distribution by Interval

 RS2.2 ACD Calls Distribution by Date

 RS3.1 Abandoned Calls Analysis by Interval

 RS3.2 Abandoned Calls Analysis by Date

Blank Templates

Contact Center provides the following blank templates for generating historical reports:

 1.1 Group by Interval

 1.2 Group by Date

 3.1 Agent by Interval

 3.2 Agent by Date

 3.3 Group Agent by Interval
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 3.4 Group Agent by Date

 3.7 Agent Groups by Interval

 3.8 Agent Groups by Date

 3.9 Agent Calls Distribution by Agent

 4.2 Group Agents by Date

 6.1 Detailed Wrap-Up Code Report by Interval

 6.2 Detailed Wrap-Up Code Report by Date

 6.3 Wrap-Up Code Report By Interval

 6.4 Wrap-Up Code Report By Date.

 6.5 Group Wrap-Up Code Report By Interval.

 6.6 Group Wrap-Up Code Report By Date.

 6.7 Agent Wrap-Up Code Report By Interval.

 6.8 Agent Wrap-Up Code Report By Date.

 6.9 Agent Group Wrap-Up Code Report By Interval.

 6.10 Agent Group Wrap-Up Code Report By Date.

 6.11 Agent Queue Wrap-Up Code Report By Interval.

 6.12 Agent Queue Wrap-Up Code Report By Date.

 7.1 Wrap-Up

 8.1 Agent Queue by Interval

 8.2 Agent Queue by Date

 12.1 DNIS by Interval

 12.2 DNIS by Date 

 13.1 Group DNIS by Interval

 13.2 Group DNIS by Date 

 13.3 DNIS Call Distribution by ACD Group

 13.4 DNIS Call Distribution by DNIS 

 14.1 Agent DNIS by Interval

 14.2 Agent DNIS by Date

 16.2 ANI Distribution by Date
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 16.5 ANI Distribution by Period

 17.1 IVR Applications Reports by Interval 

 17.2 IVR Applications Reports by Date 

 18.1 IVR Ports Groups Reports by Interval 

 18.2 IVR Ports Groups Reports by Date 

 19.2 Outbound Calls Report by Date

 19.3 Dial List by Date

 19.4 Dial List Calls by Date 

 19.6 Dial List Calls Status by Date 

 21.1 Release Codes by Interval 

 21.2 Release Codes by Date 

 21.3 Group Release Codes by Interval 

 21.4 Group Release Codes by Date 

 21.5 Agent Release Codes by Interval 

 21.6 Agent Release Codes by Date 

 21.7 Agent Group Release Codes by Interval 

 21.8 Agent Group Release Codes by Date

 21.10 Agents Release Codes by Date

Creating a Historical Report Using a Predefined 
Template

Templates are used to create reports. By default, predefined templates contains commonly used data 
fields. Predefined templates can also be customized to generate other information or to have a unique 
look. A series of predefined templates are provided in Contact Center Reports. 

A series of predefined templates are provided in Contact Center Reports. For a list of the predefined 
templates, refer to Predefined Templates on page 28.

If you want to generate reports on call activity in an IVR Application, you first need to specify the 
associated DNIS. Refer to Generating Reports on IVR Applications on page 48 for details.

The process of creating a report using a predefined template includes the following steps:

1. Launching the Open Window
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2. Viewing Only Public and/or Private Templates

3. Opening a Predefined Template

4. Specifying Template Parameters

5. (Optional)Customizing a Template

6. (Optional)Saving a Template with a New Name

7. Generating a Report

Predefined templates that you have created, by saving the template under a new name, can be 
deleted. For information, refer to Deleting a Predefined Template on page 43.

Once generated, a report can be printed, emailed, or exported, as explained in Working with Historical 
Reports on page 45.

For information about the data displayed in these reports, refer to the ShoreTel Contact Center Report 
Data Fields guide.

Launching the Open Window

You work with predefined templates from the Open window. The Open window displays a list of 
predefined templates to choose from, options to view only public and/or private templates in the list, 
and buttons to customize, generate, print, and delete templates.

To launch the Open window, click File > Open in Enterprise Contact Center Reports or click the Open 
Existing Template icon.

Viewing Only Public and/or Private Templates

Predefined templates are categorized as public or private. Public templates are available to anyone 
who uses Enterprise Contact Center Reports and can be modified by authorized users. Private 
templates can only be used and modified by you. Contact your system administrator if you want to 
modify public templates, but are unable to do so.

By default, the Open window displays the list of all available public templates. You can filter this list to 
show only your private templates, or all public and private templates.
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To filter the list of templates, select the Public check box, the Private check box, or both check boxes 
to display the appropriate templates. 

Opening a Predefined Template

You open the predefined template that you want to base your report on. 

Predefined templates provided by Enterprise Contact Center Reports are organized by entity. Entities 
are administrative objects in the ShoreTel system, upon which system operations are based. For 
example, agents, groups, super groups, and trunks. 

Refer to Starting the Supervisor Applications on page 11 for information about the predefined 
templates provided by Enterprise Contact Center Reports and for hints about choosing the correct 
template to base your report on. 

Complete the following steps to open a predefined template:

1. From the Open window, select the template you want to base your report on. You may need to 
scroll down to see the entire list of available templates.

2. If you want to customize the template, click OK.

To generate the report, click Generate.

If you have not previously specified the template parameters, use the Parameters window to define the 
parameters as explained in Specifying Template Parameters on page 33.

To print the report, click Print.

If you have not previously specified the template parameters, use the Parameters window to define the 
parameters as explained in Specifying Template Parameters on page 33.

Specifying Template Parameters

In addition to data fields, templates contain parameters. A parameter defines the reporting criteria, 
specifically the report’s entities, date range, time range, and interval (where applicable). You must 
specify a template’s parameters before the report can be generated.

Complete the following steps to specify a template parameters:

1. In an open template, right-click in the parameters area and choose Parameters.

You can also click on the Report Parameters icon.

2. Initiate the definition of the report entities by clicking on the ellipses button in the upper-left corner 
of the Parameters window. In the Choose <Entity> window, add the entities that you want to be the 
basis of the report by moving them from the Available field to the Selected field.
ShoreTel Enterprise Contact Center ShoreTel Contact Center Supervisor Guide 33



Analyzing Trends Hints for Using a Relative Monthly Date Range3
You can click Quick Search to find a specific entity. In the resulting field, enter an entity name. 
Entities with the specified name are shown at the top of the associated list.

3. Click OK. 

4. Define the template date range by clicking a Date field in the Parameters window. In the Date 
window, specify the From and To dates:

 Now Minus Days — Period of past days relative to the current day. 

 Now Minus Months — Period of past months relative to the current month.

Refer to Hints for Using a Relative Monthly Date Range on page 34 for help using this option.

 Specific — A specific from and/or to date.

 Advanced — If you have defined a Specific date range and want the template to be based on 
noncontinuous dates within the date range, click this button. In the Date Ranges window, 
define date ranges for the template:

 Date Ranges — Click if you want to use specific dates for the date ranges. Use the Add, 
Insert, Delete, and Sort buttons to list the various date ranges in the Date Ranges area of 
the window.

 Specific Days — Click if you want to base the date ranges on days of the week. Select 
the specific days.

5. Click OK.

6. Identify the template time range by clicking a Time field in the Parameters window. In the Time 
window, specify the From and To time: 

 Now Minus — Period of past time relative to the current time. 

 Specific — A specific start and/or end time.

 Advanced — If you have defined a Specific time range and want the template to be based a 
noncontinuous time within the time range, click this button. In the Time Ranges window, define 
time ranges for the template:

 Add — Click to add additional time ranges.

 Delete — Click to delete the selected time range.

7. If applicable, identify the template interval by clicking on the Interval field in the Parameters 
window. In the Interval window, specify the interval and then click OK. 

8. Click OK in the Parameters window. 

Hints for Using a Relative Monthly Date Range

A template date range can be specified relative to the current month. If you want to use a relative 
monthly date range, here are some hints:
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 If you specify a From and To relative monthly date range of 0, the report is generated from the first 
of the current month to the current day. 

 If you specify a From relative monthly date range of 1, and a To range of 0, the report is generated 
from the first of the previous month to the current day. 

 If you specify a From relative monthly date range of 5, and a To range of 5, the report is generated 
for the entire month that was five months prior. So a report with these parameters, generated on 
February 17, 2010, displays data for the month of September, 2009.

Customizing a Template

Templates can be customized by performing any of the following procedures:

 Adding and Deleting Data Fields

 Creating a Formula Field

 Rearranging Data Fields

 Adjusting the Width of a Field

 Filtering Fields

 Sorting Fields

 Editing Text

 Modifying Text Font

 Specifying Text Color

 Changing the Visual Frame around Parameters

 Identifying the Number of Rows for Field Titles

 Specifying Tabular or Graphic Display

Adding and Deleting Data Fields

Templates can contain commonly used data fields. However, you may want to change the data fields 
by adding and deleting fields.

Before deleting a field, or adding a field you may not need, check the description of the field.  Field 
descriptions are available from both an open template, and when adding a field from the Add New 
Column window. 

To view field descriptions in an open template, point your cursor on the field title. A tooltip appears with 
details on the field, including it’s formula if applicable. To view field descriptions from the Add New 
Column window, select a field that you may want to add to the template. A description of the selected 
field is shown in the Description area of the window.
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Complete the following steps to delete a data field:

1. In an open template, right-click on the title of the field you want to remove from the template.

2. From the menu, choose Delete Column. 

Complete the following steps to add a data field:

1. In an open template, right-click the field title area and select Add Column.

2. In the Add New Column window, select the field you want to add. You may need to scroll down to 
see the full list of available fields.

A description of the selected field is shown in the Description area of the window. This description 
can help you determine if the selected field is the one you want to add to the template.

If you want to find a specific field, click Quick Search. In the resulting field, enter a data field 
name.

3. Click Add Column.

Creating a Formula Field

If the default formula fields available for the template do not provide the information you need, you can 
create additional formula fields. 

Complete the following steps to create a formula field:

1. In an open template, click Tools > Formulas Editor.

2. Click New. 

3. Enter the Name of the new formula field. 

4. In Description, describe the purpose of the new field. 

This description is displayed when you select the field in the Add New Column window and in the 
tool tip for the field. 

5. In Entity, select the entity for the formula. 

The list of available fields is based on the selected entity.

6. Define the field’s Formula. A formula is a combination of predefined statistical data that appear in 
existing fields. 

The Specify Formula window provides options to make it easy for you to define a formula. Select 
the field data for the formula from the Column list, which is categorized by entity. Use the 
mathematical operators to specify the action to be taken.

Tip

The Formula Editor window contains a list of existing formula fields. You can use this window to 
edit or delete formula fields as well as create new ones.
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7. Specify the Formula Type. 

This ensures that the correct internal operators are used to format the formula, so that you get the 
expected result.

8. Click Verify to test that the formula is valid.

9. Click Save to save the formula field under its current name.

If you want to save the formula field under a different name, click Save As.

To include the new formula field in the template, you must add the field as explained in Adding and 
Deleting Data Fields on page 35.

Rearranging Data Fields

To rearrange data fields, open a template, select the title of the field you want to move, and then drag 
the field to a new position.

Adjusting the Width of a Field

To adjust the width of a field, open a template, select the title of the field you want to narrow or widen, 
and then use the cross-arrow cursor to drag the field line to the required width.

Filtering Fields

To limit the data displayed in a template or report according to a certain criteria, filter the fields that 
appear in the template or report. 

Complete the following steps to filter the fields:

1. Click Tools > Filter > Change. 

2. In Column, choose the field for the filter criteria.

3. Use the appropriate fields to select the operator and value to complete the condition. 

4. If more conditions are required, add an additional condition line to the filter by clicking Add and 
choosing a logical operator from the Logical drop-down menu.

5. To delete one of the conditions, click the condition and click Delete.

6. Click OK. 

To remove a filter from a template or report, click Tools > Filter > Clear. 

Sorting Fields

You can arrange data in a template or report according to a particular criteria. To do so, you sort the 
fields that appear in the template or report.
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Complete the following steps to sort fields:

1. Click Tools > Sort > Change. 

2. Drag and drop the appropriate fields from and to the Columns Available for Sorting and Sort 
Columns lists.

3. If you want the field order to be ascending, select the Ascending check box associated with the 
field.

4. Click OK. 

To remove a sort criteria from a template or report, click Tools > Sort > Clear. 

Editing Text

You can edit the text shown in a template. This includes the title of the template, the parameter 
descriptions, and the data field titles.

Complete the following steps to edit the text in a template:

1. In an open template, right-click the text you want to change and choose Text.

2. In the Text Modification window, highlight the text shown and type the new text.

3. Click OK.

Modifying Text Font

The font size and style used for template text can be modified. This text includes the title of the 
template, the parameter descriptions, and the data field titles.

Complete the following steps to modify template text:

1. In an open template, right-click the text you want to change and choose Font.

2. In the Font Modification window, specify the font size and style.

3. Click OK.

Specifying Text Color

You can specify the color of template text. This text includes the title of the template, the parameter 
descriptions, and the data field titles.

Complete the following steps to specify the color of text:

1. In an open template, right-click the text you want to change and choose Color.

2. In the Color Modification window, use the sliders to select the amount of red, green, and blue you 
want in your color.
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The Color Modification window uses the RGB color model. The RGB value for each color is 
displayed in the associated color box. The X shows the actual color. 

3. Click OK.

Changing the Visual Frame around Parameters

The parameters area of the template can be set off with a visual frame. By default, the frame is raised. 
You can change the frame to a simple box, or remove it entirely.

Complete the following steps to change the visual frame:

1. In an open template, right-click the Parameters area and choose Frame.

2. Select the type of frame you want to use:

 None — The parameters area is not set off.

 Boxed — The parameters area is set off by a simple box.

 Raised — The parameters area is set off by a raised box.

Identifying the Number of Rows for Field Titles

By default, data field titles are shown on three rows. Complete the following steps to change this 
configuration:

1. In an open template, right-click a data field title and choose Number Header Row.

2. In the Number of Rows window, select the number of rows the data fields titles are to be displayed 
across.

3. Click OK.

Specifying Tabular or Graphic Display

To determine how the data displays, select the type of display in the Report Type area.

Once the graphical report is displayed, you can view additional details, configure the graph colors, 
show point labels, and hide the legend. You can point your mouse to a graph sector to see the numeric 
or percentage value for that sector.

Tip

To display data as a graph, ensure the template does not have more than six data fields.
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Saving a Template with a New Name

If you have specified the parameters of a template or customized it, and you want to use the template 
again, you can save it under a new name. Templates modified in this manner are considered 
predefined templates, and are accessible from File > Open. 

Complete the following steps to save a template with a new name:

1. Click File > Save As or click the Save Template As icon on the toolbar.

2. In the Save As window, enter the new Template Name.

3. Identify the template as either public or private by clicking on the appropriate option.

4. Click OK.

Once you have created a new template, you can save any additional changes you make by clicking 
File > Save or clicking on the Save Template icon on the toolbar.

Generating a Report

There are three ways to generate a report from a template: from the Open window, manually, or by 
scheduling the report to be automatically generated at a later time. 

Generating a Report from the Open Window

Generating a report from the Open window allows you to generate a report without having to open the 
template. This method is useful when you have a template in which you have already specified the 
parameters, and if required, customized it with the data fields and look that you want.

Complete the following steps to generate a report from the Open window:

1. From the Contact Center Reports File menu, click Open. You can also click the Open Existing 
Template icon on the toolbar.

2. Select the template you want to generate a report from, and then click Generate. 

If you have not previously specified the template’s parameters, the Parameters window opens, 
which you must use to define the parameters, as explained in Specifying Template Parameters on 
page 33.

The report is automatically generated and opens in a new window.

3. If you generated a graphical report, you can choose how the graphic data is displayed. From the 
Report menu, choose Graph Type, and then the specific graph you want.

You can now print or email the report, or export the data to a file format. Refer to Working with 
Historical Reports on page 45 for information.
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Manually Generating a Report

Manually generating a report allows you to view and use the data immediately. 

Complete the following steps to manually generate a report:

1. In an open template, click Report > Generate for click on the Generate Report from Template 
icon.

2. If the template’s parameters are not defined, the Parameters window opens. A template must have 
parameters before the report can be generated. Refer to Specifying Template Parameters on page 
33 for details.

3. If you generated a graphical report, you can choose how the graphic data is displayed. Click 
Report > Graph Type, and then the specific graph you want.

After you generate a report, you can print or email it or export the data to a file format. Refer to Working 
with Historical Reports on page 45 for information.

Automatically Generating a Report (Scheduling a Report)

Automatically generating a report is useful when you want to generate and print, email, or export the 
report periodically.

You must specify the template's parameters before you can automatically email a report. If you have 
scheduled a generated report to be automatically emailed, and the report is not sent, contact your 
administrator. The administrator must create a printer account with local administrative privileges on 
the Contact Center server to ensure that scheduled reports are emailed successfully.

Once you have scheduled a report to be automatically generated, you can view and manage the 
schedule on the Schedule List. Refer to Managing Scheduled Reports on page 48 for details.

You can schedule up to 30 reports per specified 15 minute interval. If more reports are scheduled, the 
31st report and any additional reports are generated in the following interval.

Complete the following steps to automatically generate a report:

1. In an open template, choose Schedule from the Report menu, or click on the Define an 
Automatic Report icon.

The Source Report Name field indicates that template that the report is based on.

2. In the Schedule tab, specify the schedule name and options. 

To keep the new schedule up-to-date with any changes made to the template on which it is based, 
select the Synchronize with the source template (parameters, design) check box. This option 
is only available for templates you have previously saved.

3. Use the options in the Date and Time areas to identify when the report is to be generated. 

 Every Day — Run the report every day of the week, unless the Generate the report on 
working days only option is checked.
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 Every Week — Run the report once a week, on the day specified in the associated field. 

 Every Month — Run the once a month, on the date specified in the associated field.

 Specific — Generate the report on this specific day only.

 Every Hour — Generate the report every number of specified hours. 

 Specific — Generate the report at this specific hour only. 

4. If you want to generate the report to a printer, click the Destination tab and check Printer. 

The report is sent to your default printer. To select a different printer from the list defined in the 
Contact Center server, click Browse. You can choose the report page orientation from the 
Orientation area. Default uses the specified printer’s default orientation.

5. If you want to generate the report to a file, click the Destination tab, check File, and select the 
appropriate file options:

 File Path — The location the file is to be saved on the Contact Center server. Click Browse to 
navigate to and select a location.

 Base File Name — By default, the report is saved with the name of the schedule. You can 
change the report name or restore the default name.

 Full File Name — Specify the full file name. You can include the base file name, file Format, a 
Suffix, and the file extension. 

 Type — The file format type of the report. Note that if you want to export the report to PDF, 
your administrator has to first install a required component on your machine. If you are unable 
to export reports to PDF, contact your administrator.

Note

Make sure the printer does not require that you specify a filename before printing (for example the 
Microsoft Office Document Image Writer). Devices that require you to specify a filename before 
printing will cause the Contact Center Scheduler to hang, since user input is required.

Note

As of ECC 8, reports are generated in the following formats:

 comma separated values (*.csv files)

 enhanced metafile format (*.emf files)

 Microsoft Excel format

 Portable Document Format (PDF)

 SQL syntax

 Text with HTML format

If you have upgraded from a version prior to ECC 8 and you have created scheduled reports 
that generate in any other file format, you may get a report generation error. To correct this 
issue, update Type for the affected report.
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 Available Options — Depending on the type of file format you selected, three type options 
may become available: Append Report Parameters, Append Total Rows, and Append 
Subtotals.

 Append Date/Time — Adds the date and/or time to the file name.

 Format — If the Append Date/Time option is checked, select the date and time format you 
want to use. 

 Suffix — If Suffix is selected, the system adds the suffix entered in the edit box at the end of 
the file name.

 Keep — Defines how many copies of the same file are kept. If a file with the same name is 
generated (for example, if Suffix was selected but Append Date/Time was not selected), the 
system renames the previous file by adding the generation number to the name. If the 
generation number is exceeded, the system removes the oldest copy.

 Email Report — Checking Email Report sends the report as an email attachment.

 Delete File After Sending — If checked, after the email is sent the report file is automatically 
deleted from your machine.

 To — The address(es) the report is to be sent to.

 From — The address the report will be sent from.

 Subject — The subject of the email.

 Append Date/Time — Appends the date and time of the email to the subject line.

 Format — If the Append Date/Time option is checked, select the date and time format you 
want to use.

 Append Report Name — Appends the report name to the email subject line.

 Resulting Subject Text — Displays the subject line of the email based on the specified 
options.

6. Click OK.

Deleting a Predefined Template

Complete the following steps to delete a predefined template:

1. Click File > Open or click the Open Existing Template icon on the toolbar.

2. In the Open window, select the template you want to delete, and then click Delete.

3. Click Yes in the resulting confirmation message.

If the Delete button is inactive, you can not delete that template.
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Creating a Historical Report Using a Blank Template

Templates are used to create reports. Generally, it is recommended to base your historical reports on 
predefined templates because they contain commonly used data fields. However, if your data needs 
are not met by a predefined template, Contact Center Reports provides a series of blank templates to 
use instead. For a list of the blank templates, refer to Starting the Supervisor Applications on page 11.

The process of creating a report using a blank template includes the following steps:

1. Opening a Blank Template

2. Adding Fields to the Template

3. Specifying Blank Template Parameters

4. Customizing a Blank Template (Optional)

5. Saving a Blank Template with a New Name

6. Generating a Report from a Blank Template

Once generated, a report can be printed, emailed, or exported, as explained in Working with Historical 
Reports on page 45.

Opening a Blank Template

The blank templates provided by Contact Center Reports are organized by entity. Entities are 
administrative objects in the ShoreTel system, upon which system operations are based. For example, 
agents, groups, super groups, and trunks. 

Complete the following link to open a blank template:

1. Click File > New or click the Create New Template icon on the toolbar.

2. From the New window, select the template you want to base your report on, and click OK. 

Adding Fields to the Template

Complete the following steps to add a data field:

1. In an open template, right-click in the data field title area and choose Add Column.

2. In the Add New Column window, select the field you want to add. 

Refer to the Description of the selected field to determine if is the one you want to add to the 
template.

3. If you want to find a specific field, click Quick Search. In the resulting field, enter a data field 
name.

Data fields with the specified name are shown at the top of the list of available fields.
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4. Click Add Column.

Specifying Blank Template Parameters

In addition to data fields, templates contain parameters. A parameter defines the reporting criteria, 
specifically the report’s entities, date range, time range, and interval, where applicable. You must 
specify a template’s parameters before the report can be generated.

Refer to Specifying Template Parameters on page 33 for more information.

Customizing a Blank Template

Blank templates can be customized in the same ways as predefined templates. Refer to Customizing a 
Template on page 35 for details.

Saving a Blank Template with a New Name

After you have added data fields to a blank template, specified the parameters, and customized the 
template, you can save the template under a new name. Refer to Saving a Template with a New Name 
on page 40 for details.

Saved templates are considered to be predefined templates and are accessible from the Open 
window. 

Generating a Report from a Blank Template

There are two ways to generate a report, either manually or by scheduling the report to be 
automatically generated at a later time. 

Refer to Manually Generating a Report on page 41 and Automatically Generating a Report 
(Scheduling a Report) on page 41 for specifics.

Working with Historical Reports

After a report has been generated, you can perform the following functions on the report: 

 Filtering Fields in a Report

 Sorting Fields in a Report

 Magnifying a Report

 Printing Reports

 Automatically Emailing Reports

 Exporting Report Data
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 Managing Scheduled Reports

Filtering Fields in a Report

Sometimes you may need to omit data in a report according to a certain criteria. In order to do so, you 
can filter the fields that appear in the report, as explained in Filtering Fields on page 37.

Filters defined for reports can not be saved. In filtered reports, although some records are filtered out, 
the “total” line calculates the totals as if those filtered records were part of the report. 

Sorting Fields in a Report

You can arrange data in a report according to a particular criteria. Refer to Sorting Fields on page 37 
for more information.

Sort criteria can not be saved with a report. 

Magnifying a Report

Generated reports can contain a lot of data that may be difficult to see on screen. You can change the 
magnification of a report to display more or less information without scrolling.

To magnify a report, open a report, click Tools > Zoom, select the magnification you want to use, and 
click OK.

Printing Reports

There are three ways to print a report from a template: from the Open window, manually, or by 
scheduling the report to be automatically generated and printed at a later time. 

Before printing a report, click File > Printer Setup to identify your printer.

If your report is in PDF format and prints with an extra blank page for each page printed, change the 
scaling settings for your printer. Refer to your Windows documentation for information about 
completing this procedure.

Printing a Report from the Open Window

Printing a report from the Open window allows you to print a report without having to open the 
template. This method is useful when you have a template in which you have already specified the 
parameters, and if required, customized it with the data fields and look that you want.

Complete the following steps to print a report from the Open window:

1. In Contact Center Reports, click File > Open or click the Open Existing Template icon on the 
toolbar.

2. In the Open window, select the appropriate template, and then click Print.
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3. If you have not previously specified the template’s parameters, the Parameters window opens, 
and you must define the parameters before you can print the report. Refer to Specifying Template 
Parameters on page 33 for more information.

Manually Printing a Report

Manually printing a report allows you to view and use the data immediately. 

To manually print a report, open the report, and click File > Print or click the Print Report icon.

Automatically Printing a Report

Automatically printing a report is useful when you want to generate and print a report periodically. 
Refer to Automatically Generating a Report (Scheduling a Report) on page 41 for information.

Automatically Emailing Reports

You can automatically generate and email a report periodically, as detailed in Automatically Generating 
a Report (Scheduling a Report) on page 41.

Exporting Report Data

Report data can be exported to various file formats. There are two ways to export report data: 
manually or by scheduling the report to be automatically generated and exported at a later time. 

The supported export file formats for historical reports are:

 Comma-Separated Values (.CSV)

 Enhanced Metafile Format (.EMF)

 Microsoft Excel (.XLS)

To export a report to the XLS format, before beginning the export process make sure to widen the 
first field in the report template. This ensures that the subtotals in that field are displayed.

 Portable Document Format (.PDF)

To export a report to PDF, your administrator has to first installed a required component on your 
machine. If you are unable to export reports to PDF, contact your administrator.

 SQL Syntax (.SQL)

 Text with HTML Formatting (.HTM)

Manually Exporting Report Data

Manually exporting report data allows you to view and use the data immediately. 
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Complete the following steps to manually export a report:

1. In an open report, click File > Export or click on the Export Report Content icon.

2. Specify the File Name and Type, select Available options, if applicable, and then click Save.

3. If you want to change File Name, Type, or Available options for the export file, click Browse to 
specify the new information.

4. Click Export Data.

Automatically Exporting Report Data

Automatically exporting report data is useful when you want to generate and export a report 
periodically. Refer to Automatically Generating a Report (Scheduling a Report) on page 41 for 
specifics.

Managing Scheduled Reports

Once you have scheduled a report to be automatically generated, you can view and manage the 
schedule on the Schedule List.

Complete the following steps to manage scheduled reports:

1. Click File > Schedule List. 

2. To change the schedule parameters, select the schedule to change, and click Edit. 

Refer to Automatically Generating a Report (Scheduling a Report) on page 41 for information 
about changing the schedule parameters. 

3. Click Delete to remove a selected schedule from the list. 

4. Click Log to get information on the outcome of the schedule.

Generating Reports on IVR Applications

If you want to generate reports on voice call or email activity in an IVR Application, you first need to 
specify the associated DNIS. 

A DNIS number is a series of digits that identifies to Contact Center the number that was dialed by the 
caller. The DNIS number is used to collect statistics on the Contact Center activity that is routed 
through specific entry points that a customer dials. 

Tip

Deleting a selected schedule from the list does not delete the template the schedule is based on.
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Complete the following steps to specify a DNIS for an IVR application for voice calls:

1. From Contact Center Director, select Routing > DNIS. 

2. To create a new DNIS, click New, enter the required options, and click Create.

3. To edit an existing DNIS, select the DNIS, enter the required options, and click Save.

The following list includes the DNIS options:

 Name — A unique name for the DNIS.

 Number — The IRN number represented by the DNIS as an entry point for voice or chat 
contacts.

 Target ASA — Target Average Speed of Answer. The amount of time during which the call 
should be answered from the time it is received. This parameter is used to calculate the DNIS 
Target Service Factor (TSF).

 Short Calls Threshold — The amount of time (in seconds) in which a call must end to be 
counted as a too short call in the historical reports.

 Max ACD Talk Time — The amount of time (in seconds, in case of a Voice or Chat DNIS, or in 
hh:mm in case of an email DNIS) that a call must exceed to be counted as a too long call in 
the historical reports.

 Interval Time — Determines the time period that will be monitored in the real-time reports for 
the DNIS. If this field is set to ten minutes, for example, the real-time report for that DNIS will 
show statistical information relevant to the last ten minutes.

 Service Time Intervals — This parameter determines the time intervals in which calls are 
monitored. The calls can be viewed in STI histogram reports that show the number of calls 
answered, abandoned, and waiting in each given interval.

Complete the following steps to specify a DNIS for an IVR application for email:

1. From Contact Center Director, select Email > Email DNIS. 

2. To create a new email DNIS, click New, enter the required options, and click Create.

3. To edit an existing email DNIS, select the email DNIS and enter the required options, and then 
click Save.

The email DNIS options are as follows:

 Name — A unique name for the DNIS.

 Email Account — The email account represented by the DNIS.

 Target ASA — The amount of time in which the email should be answered from the time it is 
received, and is used to calculate the DNIS Target Service Factor (TSF).

 Short Calls Threshold — The amount of time in which interaction with an email must end to 
be counted as “too short” in historical reports.
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 Max ACD Talk Time — The amount of time that interaction with an email must exceed to be 
counted as “too long” in historical reports.

 Interval Time — The time period that will be monitored for realtime reports for the email DNIS

 Service Time Intervals — The time intervals in which emails are monitored. Statistics on the 
emails can be viewed in STI histogram reports that show the number of emails waiting in each 
given interval.

Understanding Historical Report Results

This section provides information about the data displayed in historical reports.

Data on Deleted Agents

You can retrieve historical data on agents that have been deleted from Contact Center Director using 
the Group report templates (such as the 3.4 Group Agent by Date Report). If the parameters of the 
report (i.e. group and date) are appropriate for the removed agent, the agent is listed in the report with 
an asterisk. 

Note that Agent historical reports and real-time reports do not display data for deleted agents.

How Agent Actions Affect Dial List Data

The Agent Toolbar Callback buttons, used by agents to work with callbacks, do not directly trigger the 
success or failure of outputs of an outbound dial list. Callback button usage is recorded on a per dial 
list, per period, basis. Refer to ShoreTel Enterprise Contact Center 8 Using Agent Toolbar for 
information about how agents should use these buttons.

The Set Callback – Reinsert Busy and Set Callback – Reinsert No Answer buttons reinsert the 
number back into the list. These numbers are called back at a later time based on the Retry on Busy 
and Retry on No Answer options specified in System Parameters > Outbound > General 
Preferences in Contact Center Director. 

The Set Callback – Reinsert Terminate button removes the number from the dial list. These entries 
are only retained for each instance of a dial list. For example, if the Start Periodically option is set to 
weekly for the dial list, the number will not be called back for that period. However, if the same record 
is imported again, during the next period it will be called.

Updates to Your External Database Records

The following table lists the updates made to your external database call records as the result of agent 
activity.
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How Inbound ACD Call Numbers are Calculated

When viewing the data for the number of inbound ACD calls, keep in mind that if a call is transferred to 
the IRN of Group A from Group B, the call is considered a new call, and is therefore counted twice in 
the inbound ACD call fields.

Measuring Email Queue Time

Email queue time measures only the length of time an email is queued in a service. It does not 
measure the time taken to download an email from the main email server or the amount of time the 
email was in the cache.

Unexpected Results when using Park

Parking a call places a call on hold on another extension. This allows agents to park a call on one 
extension and pick it up from a different extension. Unparking a call is retrieving a call that an agent 
previously parked on another extension. Calls can be unparked only by the person that parked it.

Park and unpark is not supported in Contact Center. So if you implement this feature in your call 
center, note that the data recorded when a call is parked is not completely accurate and you may get 
unexpected results in your reports. In addition, using park can cause agent states to get stuck or be 
incorrect.

Update Reason

Record is marked as Final Failure. The system was unable to dial the number; or

The number was successfully dialed by the system, but 
marked Callback Terminate by the agent.

Record is marked as First Failure. One or more numbers (but not all) could not be dialed by the 
system; or

One or more numbers (but not all) were successfully dialed by 
the system, but marked Callback Terminate by the agent. 

Record is marked as Successful One number was routed to the agent, and was successfully 
answered and disconnected without being reinserted into the 
list.
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CHAPTER
4. Communicating with Agents

Wallboard Director enables you to communicate with entire groups of agents simultaneously, while 
providing you with important information instantaneously.

Using Wallboard Director, you can create and store new wallboard messages, modify existing 
messages, and customize messages for individual groups. You also can create customized scenarios, 
which may include messages and pop-ups. Pop-ups display a message at a specific time for 
predefined periods.

Contact Center supports single and two line LED Wallboards from Spectrum Corporation 
(www.specorp.com.) 

Refer to the following sections for more information about communicating with agents:

The Wallboard Director Main Screen ........................................................................  52

Message Editor Window ...........................................................................................  53

Changing the Message Colors..................................................................................  57

Parameter Group Assignment Rules ........................................................................  57

The Wallboard Window .............................................................................................  58

The Wallboard Director Main Screen

The Wallboard Director main screen is displayed after you have successfully logged onto the 
application. The main screen comprises a menu bar with menu options, and a toolbar with two tool 
icons that provide you with quick access to the most frequently performed procedures.
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The toolbar provides the following functions:

 Wallboard (1) — Opens the Wallboard window.

 Logout (2) — Exits Wallboard Director and any other currently open Contact Center supervisor 
applications.

Message Editor Window

The Message Editor window is used to create and edit messages to be displayed on the wallboard.

A new message can be created, or an existing one can be edited, using the following fields and 
buttons in the Message Editor:

 Message Library — Displays the messages available for use in the wallboard. Each time a new 
message is created, it is placed in the Message Library. The Message Library is displayed both in 
the Message Editor window and the Wallboard window in the same format. A message is not 
removed from the list after being added to a scenario, thereby enabling you to use any message 
an unlimited number of times.

 Message Name — Shows the name of the selected message. When creating a new message, 
you must fill in this field. When modifying an existing message, you have the option to change the 
message name. The message name can contain a maximum of 32 characters.

 Default Group — For parameters in a message, a group must be assigned to be displayed. The 
parameter’s group may be defined in various stages during the process of inserting a message 
into a scenario or a pop-up.

 Line 1 — Displays the first line of the selected message. This read-only area displays 
modifications made to the message in the work area of the Message Editor window. Each set of 
parentheses represents a parameter that has been included in the message.

 Line 2 — Displays the second line of the selected message. This read-only area displays 
modifications made to the message in the work area of the Message Editor window. Each set of 
parentheses represents a parameter included in the message.

 New — Click to create a new message. All the fields in the Message Editor are cleared, except for 
the Message Library. All the fields in the Message Editor must be filled in for a new message to be 
complete.

 Delete — Click to erase a selected message. A warning appears. Click Yes to delete the message 
or No to cancel the process.

 Cancel — Click to undo any changes you have made and return to the original message.

 Parameter — Click to open the parameter dialog box, in which you can select preset parameters 
from the Parameters list. Parameters selected from this list are included in the message.

 Message Area — Area to enter and edit messages.
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Each box represents one character, and the paragraph marks represent parameters included in 
the messages. You can change the color of individual characters by right-clicking their boxes. 
Each line has 40 characters, for a total of 80 characters. The two lines of the message area are not 
continuous. Therefore, a message that begins on Line 1 and extends longer than 40 characters 
does not automatically continue on the next line. You must either press ENTER or click where you 
want the message to continue.

 Help — Click to open Wallboard Director Help.

Complete the following steps to create a new message:

1. In the Messages Editor window, click New. 

2. In the Message Name field, enter the name of the new message.

3. In the Default Group field, from the drop down list, select the default group for the message. Refer 
to Parameter Group Assignment Rules section on page 57 for details.

4. In the work area, type the new message.

5. If you need to add a parameter to the new message, place the cursor where you want the 
parameter to appear within the message, and click Parameter.

6. When you have finished editing the message, click OK in the Message Editor window to save the 
new message. The new message’s name appears in the Message Library.

When using the Message Area in the Message Editor, keep the following few rules in mind:

 Wallboard Director does not accept single quotes (') and the Spectrum wallboard either does not 
display or incorrectly displays the following characters: ^\üä0ß. The Agentboard displays all 
characters except the backward slash (\).

 To begin typing, position the cursor where you want to begin the message, and click the mouse.

 Clicking the spacebar on the keyboard inserts a small rectangle in the box (representing a space in 
the message). You cannot type another character in a box with a space rectangle until you delete 
the space.

 You can highlight a block of text and press either DELETE or BACKSPACE on the keyboard to 
erase the selected text.

 Parameters cannot be modified in any way, but you can remove them from, or add them to, 
existing messages.

Complete the following steps to edit a preprogrammed message:

1. In the Message Editor window, select the message that you want to edit from the Message Library.

2. Make any corrections within the Message Editor or the Parameters window.

3. When you have finished making the corrections, click OK. 

Complete the following steps to delete a message:

4. In the Message Editor, click the message that you want to delete.
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5. Click Delete. 

6. Click Yes to delete the message, or click No to cancel. 

Deleting a message removes it from any scenario in which it appeared.

Adding Parameters to a Message

The messages displayed on the wallboard often contain important information that supervisors may 
want to convey to agents. This information can be taken from real-time reports by specifying a 
predefined parameter. Each message can have its own combination of parameters, which represent 
information in a group.

Complete the following steps to add message parameters:

1. Place the cursor where you want the parameter to appear within the message, and click 
Parameter. 

2. From the Group list, select one of the groups to which the selected parameter will refer. Refer to 
Parameter Group Assignment Rules section on page 57 for details. 

3. The Parameter list displays all the various parameters that can be added to a message. The 
Length field below the Parameter list indicates the maximum number of characters used to 
present the parameter’s value. To modify the displayed length, click the field and enter the required 
number.

For example, you may have a message that informs the agents in the Sales group of their 
progress in answering calls. Click Sales in the Group field, and then select ASA from the list of 
parameters. This parameter indicates the Average Speed of Answer by the agents. Thus, when 
this parameter is included, a number indicating the ASA follows the message.

4. To add the parameter to the message, click OK. 

The new or modified parameter is added to the message and displayed in the work area of the 
Message Editor in the form of paragraph marks. The number of paragraph marks reflects the 
number of characters the parameter will take on the wallboard as defined in the Length field in the 
Parameters window.

If a message is assigned to a scenario or popup message, you can not add or delete parameters.

From the Parameters List, you can select any of the following parameters to be included in your 
message:

 General Parameters

 Grp name — Use to display the name of the group.

 Currently in Queue

 Queue calls — Number of Incoming ACD calls waiting in the groups queue.

 Above T.ASA — Number of Incoming ACD calls waiting in the groups queue more than T.ASA 
seconds.
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 Avg queue time — Average wait time of Incoming ACD calls waiting in the groups queue.

 Max queue time — Longest wait time of Incoming ACD calls waiting in the groups queue.

 STI 1 - STI 6 — One more step in the STI will be the target ASA, to see how many calls wait 
more than the target ASA.

 Information For Now

 Agents — Number of logged in agents.

 Rls agns — Number of agents in release state.

 Wr-Up agns — Number of agents in wrap-up state.

 Idle agns — Number of agents in idle state.

 ACD agns — Number of agents on an ACD call.

 Non-ACD agns — Number of agents on a non-ACD call.

 Too long talk — Number of agents who have been on a call for too long.

 Max talk time — Longest ACD call talk time (min:sec)

 On The Current Time-Interval

 TSF — The TSF for the current time-interval

 Inc calls — Number of Incoming ACD Calls

 Ansd calls — Number Of Answered ACD Calls

 % ansd calls — Percentage Of Answered ACD Calls out of all incoming ACD calls

 Abnd calls — Number Of Abandoned Calls

 % abnd calls — Percentage Of Abandoned Calls out of all incoming ACD calls

 Avg time abnd — Average Wait Time Of Abandoned Calls (sec)

 Max time abnd — Longest Wait Time Of Abandoned Calls (sec)

 Avg calls in que — Average Number of Calls in Queue

 RPH — The Groups RPH. Calculated as the number of answered calls divided by the average 
number of agents, thus giving the average number of calls answered by an agent of the group

 Avg que time on — Average Wait Time In Queue (sec)

 Max que time on — Longest Wait Time In Queue (sec)

 Avg ACD talk on — Average ACD Talk Time (min:sec)

 Max ACD talk on — Longest ACD Talk Time (min:sec)

 ASA — Average Answer Time (sec)
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 RQD agns — Required Number of Agents In Order To Meet The Target-ASA

 T ASA — Not a statistical parameter but displays the target ASA for the group as defined by 
the administrator

 On The Previous Time-Interval

 TSF LP — The TSF for the Last Period

 RQD agns LP — Required Number of Agents in Order to Meet the Target-ASA in Last Period

 Abnd LP — Number of Abandoned Calls in Last Period

Changing the Message Colors

Wallboard Director supports multiple background and foreground colors. The foreground color is the 
text color. The Message Editor window enables you to change these colors.

Complete the following steps to change the colors:

1. In the work area of the Message Editor, highlight the area on which to apply the color changes.

2. In the work area, right-click the mouse to open the Select Colors window.

3. Select a color:

 Blue — Background is blue; text is yellow

 Yellow — Background is yellow; text is blue

 White — Background is white; text is black

 Red — Background is red; text is black

 Green — Background is green; text is black

4. To configure text to blink on the wallboard, select Blink.

Parameter Group Assignment Rules

For any parameter in any message, a group must be assigned to be displayed. The parameter’s group 
may be defined in various stages during the process of inserting a message into a scenario or pop-up:

 In the Add/Edit message to scenario/pop-up dialog box, there is an option to assign the parameter 
to a specific group, for each parameter in the message. 

 In the Add/Edit message to scenario/pop-up dialog box, there is also an option to define a default 
group that, if defined, is used for every parameter that has no group assigned in the previous 
stage.
ShoreTel Enterprise Contact Center ShoreTel Contact Center Supervisor Guide 57



Communicating with Agents The Wallboard Window4
 In the Message Editor, in the Select Parameter dialog box, there is an option to assign the 
parameter to a specific group. This assignment is used if no assignment was made in one of the 
previous options.

 In the Message Editor, there is an option to define a default group for the message. This group is 
used for every parameter that was not assigned to a group in any of the previous stages.

The Wallboard Window

The Wallboard window enables you to add and remove wallboards and to “run” the scenario or pop-up 
when the message changes. The Wallboard window contains three tabs: Config, Scenario, and Pop-
Up. 

Config Tab

The Config tab is used to define the communication parameters of the selected wallboard. You can 
create a single wallboard for all your agents, or individual wallboards targeted to specific agents (up to 
256 separate wallboards). 

Some Spectrum wallboards support narrow fonts. You can use narrow fonts with these wallboard by 
adding the following statement to the wecc.ini file (located in the ShoreTel\Contact Center\Server 
directory):

[RBE]
Narrow_mode = 1

Wallboards are created and edited using the following fields and buttons in the Wallboard window 
Config Tab.

 Name — Displays the name (up to 32 characters) of the selected wallboard.

 Lines — The number of lines in the wallboard.

 Type — Drop-down list containing the following options to select the type of wallboard currently 
being used:

 AgentBoard — No actual wallboard. The messages appear on the agent’s computer using 
the Agent Board application.

 Comfuture — This wallboard conforms to the comfuture wallboard protocol.

 Spectrum / Alpha — This wallboard conforms to the Spectrum wallboard protocol. 

 Address — Contains the address of the wallboard connected to the COM port. When using 
chained wallboards, each wallboard must use a different address.

 Com Port — Click one of the option buttons in this area to define the com port to which the 
wallboard is connected.
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 Threshold Colors — Thresholds are specific event values that, if exceeded, are marked by 
special colors. These colors are used in the wallboard to show values that have exceeded the 
threshold values. The color on the right indicates that the threshold of calls is almost reached and 
could become a problem. The color on the left indicates that the threshold has been surpassed 
and a major problem is at hand. You can change the colors by double-clicking the mouse button 
and using the Select Colors window.

 Save — Saves the data choices that have been entered and return to the wallboard main window.

 Cancel — Undo any actions you performed or any new data you have entered. You will return to 
the previous window without saving any changes.

Complete the following steps to create a new wallboard:

1. Click New. 

2. Enter the Name of the new wallboard.

3. Enter the information in the other configuration fields.

4. In the Scenario and Pop-Up windows, create the new wallboard message scenario.

5. Click Save.

Changing Threshold Colors

Thresholds are specific event values that, if exceeded, are marked by special colors. These colors are 
used to show values that have exceeded the threshold values. Two colors are used to signify that a 
parameter has exceeded its threshold. The default colors are yellow and red.

Complete the following steps to change the threshold colors on the wallboard:

1. In the Wallboard window, click the Config tab. 

2. In Threshold Colors, double-click the color you want to change.

3. Select a color:

 Blue — Background is Blue; text is Yellow

 Yellow — Background is Yellow; text is Blue

 White — Background is White; text is Black

 Red — Background is Red; text is Black

 Green — Background is Green; text is Black

4. To configure text to blink on the wallboard, select Blink.
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Scenario Tab

The Scenario tab is used to define the message scenario for the selected wallboard. A message 
scenario is a sequence of messages. Each message within the scenario is displayed on the wallboard 
for a specific amount of time. 

The Message Library lists all messages created in the Message Editor. The Scenario Table contains 
the names of the messages in the order they appear along with the display time, in seconds.

The six buttons on the tab allow you to edit the scenario as follows:

 Up arrow — Moves the selected message up within the message scenario.

 Down arrow — Moves the selected message down within the message scenario.

 Add — Opens the Add Messages to the Scenario window and add a message to the message 
scenario.

 Edit — Edits the selected message within the scenario; for example, to change the amount of time 
the message will be displayed or to change the group to which the message is directed. The Edit 
Message window opens.

 Remove — Removes a selected message from the Scenario Table. Note: The message is not 
removed from the Library.

 Message Editor — Opens the Message Editor and edit the selected message.

Complete the following steps to create a message scenario:

1. Select a wallboard and click the Scenario tab. 

2. In the Message Library, select a message to be added to the message scenario, and click Add.

3. Enter the amount of Time, in seconds, that you want the message to appear on the wallboard.

4. In Default Group, enter the appropriate group. 

This group will be used for any parameter not specifically assigned a group in the next step.

5. Using the up and down arrows, select a parameter in Param #. 

6. Note that the selected parameter is highlighted in the message area, and the parameter’s name 
appears in the Name field.

7. Change the Group assignment for this field. 

If you do not assign a group for a field, the parameter will display values related to the default 
group selected in step 4.

8. Click OK to include the message in the scenario.

Repeat this procedure until all required messages are included in the scenario. A message can be 
used more than one time in a scenario.
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To change the position of a message within the scenario, click the message in the scenario and use 
the Up/Down arrow buttons to either promote or demote the selected message.

Add/Edit Message in a Scenario Dialog Box

The Add/Edit Message dialog box is displayed when you click the Add/Edit buttons in the Wallboard 
window in the Scenario tab.

The Add/Edit Message in a scenario dialog box contains the following fields:

 Time —The time, in seconds, that the message appears on the wallboard.

 Default Group —The default group is automatically assigned to every parameter in the message 
not assigned to a specific group.

 Param # — Use this section to assign a parameter to a group other than the default group. Use 
the up and down arrows to select a parameter, and then change its assignment to a group using 
the Group list box.

 Name — Displays the selected parameter name.

 Group — Changes the assignment of the selected parameter to a different group.

Pop-Up Tab

The Pop-Up tab is used to define the pop-up for the selected wallboard. A pop-up is a message that 
appears at a specific date and time or at specific time intervals. The Pop-Up tab enables you to define 
when and how these messages are shown on the wallboard.

The Messages Library lists all the messages created in the Message Editor. The Pop-Up table, on the 
right-hand side of the window, contains the message names and the date and time of their 
appearance.

Four buttons enable you to edit the Pop-Up window:

 Add — Adds a selected message to the pop-up list on the right-hand side of the window. The Add 
Message window opens.

 Remove — Removes a selected message from the pop-up list.

 Message Editor — Opens the Message Editor and edit the selected message.

 Edit — Edits the selected pop up message within the scenario (for example, to change the amount 
of time or the intervals that the message will be displayed).

Complete the following steps to insert a pop-up message to a scenario:

1. In the Pop-Up tab, select a message to add to the Pop-Up scenario from the Message Library, and 
then click Add.

2. In From Date, enter the date when the message is to start appearing on the wallboard. 

The date must be in the MM/DD/YY format.
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3. In To Date, enter the date when the message is to stop appearing on the wallboard. 

The date must be in the MM/DD/YY format.

4. In From Time, enter the time when the message is to start appearing on the wallboard. 

The time must be in the 12 hour format (AM/PM).

5. In To Time, enter the time when the message is to stop appearing on the wallboard. 

The time must be in the 12 hour format (AM/PM).

6. In the Day of the Week area, click the days of the week you want the pop-up message to appear.

7. Select how to add a pop-up message: Concatenate to Scenario or Wipe Out. 

a. If you select the Concatenate to Scenario mode, the message is incorporated into the 
message scenario for the indicated amount of time. Enter the exact length of Time that the 
message should appear in the scenario. 

b. If you select the Wipe Out mode, the pop-up message overrides the scenario for the length of 
time that the message should appear. This type of pop-up message appears for the specified 
amount of Time and according to every time that was predefined in the every field. If two pop-
up messages are defined by the Wipe Out method and are configured to appear at the same 
time, the message with the higher Priority will display.

8. In Default Group, enter the appropriate group. 

This group will be used for any parameter not specifically assigned a group in the next step.

9. Using the up and down arrows, select a parameter in Param #. 

The parameter is highlighted in the message area, and the parameter’s name appears in the 
Name field.

10. Change the Group assignment for this field as necessary. 

If you do not assign a group for a field, the parameter will display values related to the default 
group selected in step 3.

Add/Edit Pop-Up Message Dialog Box

The Add/Edit Pop-Up Message dialog box is displayed when you click the Add/Edit buttons in the 
Wallboard window in the Pop-Up tab.

The Add/Edit pop-up Message dialog box contains the following fields:

 From Date/To Date — Select the date range in which the pop-up will be activated.

 From Time/To Time — Select the time range in which the pop-up will be activated.

 Day of Week — Select the days the pop-up will be activated.

 Method — Use this area to select between two possible modes for the pop-up:
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 Concatenate to scenario — In this mode the pop-up message is added to the scenario as if it 
were part of the scenario. It does not replace the scenario messages but is added in between.

 Wipe Out — In this mode, the pop-up message is displayed cyclically (the cycle time is 
defined by the Every parameter) for the duration defined by the Time parameter. When the 
pop-up message is displayed, it replaces the currently “supposed to be displayed” message. If 
two pop-up messages should be displayed simultaneously, the one with the highest priority will 
be actually displayed.

 Default Group — The default group is automatically assigned to every parameter in the message 
not assigned to a specific group.

 Param # — Use this section to assign a parameter to a group other then the default group. Use 
the up and down arrows to select a parameter, then change its assignment to a group using the 
Group list box.

 Name — Displays the selected parameter name.

 Group — Changes the assignment of the selected parameter to a different group.
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